You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

21 lines
624 B
Nix

{
description = "World of Warcraft related NUR";
inputs.nixpkgs.url = "github:RaitoBezarius/nixpkgs/tc";
outputs = { self, nixpkgs }:
let
systems = [
"x86_64-linux"
"i686-linux"
"x86_64-darwin"
"aarch64-linux"
];
forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system);
in
{
legacyPackages = forAllSystems (system: import ./default.nix {
pkgs = import nixpkgs { inherit system; };
});
packages = forAllSystems (system: nixpkgs.lib.filterAttrs (_: v: nixpkgs.lib.isDerivation v) self.legacyPackages.${system});
};
}